When installing a new LANDO environment from scratch and you run Composer commands with errors:

SOLVED: Lando and Composer Problem - 01

Running the command, “lando composer update” returns the error:

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - remove drupal/drupal No version set (parsed as 1.0.0)|remove drupal/core 8.7.5
    - don't install drupal/core 8.7.5|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0-alpha1|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0-alpha2|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0-beta1|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0-beta2|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.0-rc1|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.1|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.2|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.3|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.4|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.6|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.7|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.8|remove drupal/drupal No version set (parsed as 1.0.0)
    - don't install drupal/core 8.7.x-dev|remove drupal/drupal No version set (parsed as 1.0.0)
    - Installation request for drupal/drupal No version set (parsed as 1.0.0) -> satisfiable by drupal/drupal[No version set (parsed as 1.0.0)].
    - Installation request for drupal/core ~8.7.0 -> satisfiable by drupal/core[8.7.0, 8.7.0-alpha1, 8.7.0-alpha2, 8.7.0-beta1, 8.7.0-beta2, 8.7.0-rc1, 8.7.1, 8.7.2, 8.7.3, 8.7.4, 8.7.5, 8.7.6, 8.7.7, 8.7.8, 8.7.x-dev].

The problem is a known bug with Composer. You need to roll back Composer to 1.7.2 and Voila!!! It works!

SOLVED: Lando and Composer Problem - 02